Volvo Recalls Unavailable

Incident Report for Dealer - Public

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 18, 2025 - 13:00 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 17, 2025 - 17:17 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 17, 2025 - 12:51 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 19:59 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 19:04 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 18:53 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 17:46 UTC

Update

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 14:24 UTC

Identified

We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 16, 2025 - 12:44 UTC
This incident affects: Vehicle History Reports (Recalls).