Vehicle Valuation Report

Incident Report for Dealer - Public

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 18:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2025 - 17:40 UTC

Update

The issue has been identified and we are working towards a fix. Users may experience issues when viewing Vehicle Valuation Report.
Posted Oct 22, 2025 - 12:23 UTC

Update

The issue has been identified and we are working towards a fix. Users may experience issues when viewing Vehicle Valuation Report.
Posted Oct 21, 2025 - 19:32 UTC

Identified

This incident is currently being investigated. Users may experience issues when viewing Vehicle Valuation Report.
Posted Oct 21, 2025 - 15:28 UTC
This incident affected: Dealer Portal (View VVR).