Most Reports Pending on all Data Sources

Incident Report for Dealer - Public

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 20:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2026 - 19:52 UTC

Identified

We have identified an issue with one of our data providers and we are awaiting a fix. Most reports across all products are currently pending.
Posted Apr 16, 2026 - 18:59 UTC
This incident affected: Vehicle Valuation Report (Report Completion) and Vehicle History Reports (Report Completion).