Alberta Liens Unavailable
Incident Report for Dealer - Public
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 19:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 19:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 05, 2024 - 19:06 UTC
Identified
We have identified an issue with one of our providers and we are awaiting a fix. Vehicle History Reports are available to order, but Alberta lien data is pending.
Posted Sep 05, 2024 - 18:22 UTC
This incident affected: Lien Availability (Alberta) and Vehicle History Reports (Report Completion, Liens).