Quebec Registration Unavailable
Incident Report for Dealer - Public
Resolved
This incident has been resolved.
Posted Sep 08, 2024 - 12:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2024 - 12:48 UTC
Identified
We have identified an issue with one of our providers and we are awaiting a fix. Vehicle History Reports are available to order, but Quebec registration data is pending.
Posted Sep 08, 2024 - 05:09 UTC
This incident affected: Vehicle History Reports (Report Completion, Registration) and Registration Information (Quebec).