Kia Recalls Unavailable
Incident Report for Dealer - Public
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 16:57 UTC
Identified
We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports.
Posted Sep 05, 2024 - 15:40 UTC
This incident affected: Vehicle History Reports (Recalls).