A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2025 - 17:59 UTC
Identified
We have identified an issue with one of our providers and we are awaiting a fix. Reports will link to the OEM website rather than collect live recall data to avoid pending reports. This will occur for all GMC, Buick and Chevrolet VINs.
Posted Sep 10, 2025 - 16:59 UTC
This incident affected: Vehicle History Reports (Recalls).