Trade-in Widget Value Unavailable
Incident Report for Dealer - Public
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 19:17 UTC
Investigating
We are currently investigating on this issue. Trade-In-Widget is available but it's unable to generate value.
Posted Sep 05, 2024 - 18:29 UTC
This incident affected: Vehicle Trade-in Widget.