Business Portal Website Showing Blank Pages, Error Messages

Incident Report for Dealer - Public

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 16:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2026 - 20:48 UTC

Update

We have identified the issue and we are working towards a fix. Some users are unable to navigate Business Portal, order reports or view historical reports.
Posted Jun 09, 2026 - 12:46 UTC

Update

We have identified the issue and we are working towards a fix. Some users are unable to navigate the Business Portal website, order reports or view historical reports.

We have found a temporary workaround. Please contact your sales rep, or our support team for assistance if you encounter these issues.
Posted Jun 08, 2026 - 20:38 UTC

Identified

Severity - 2 - We are aware of an issue with Business Portal Website and are working towards a fix. However Legacy Dealer Portal Website is up and functional.
Posted Jun 08, 2026 - 19:42 UTC
This incident affected: Business Portal (Next‑Generation – Limited Access) (Business Portal Website, Order VHR, View VHR, Order Market View, View Market View, Market View Days to Sell, Market View Comparable, Order VVR, View VVR, VVR Disclosure Form).