We have identified an issue with one of our providers and we are awaiting a fix. Vehicle History Reports are available to order, but Ontario registration data is pending.
Posted Nov 14, 2024 - 00:21 UTC
Identified
We have identified an issue with one of our providers and we are awaiting a fix. Vehicle History Reports are available to order, but Ontario registration data is pending.
Posted Nov 13, 2024 - 23:09 UTC
This incident affected: Vehicle History Reports (Report Completion, Registration) and Registration Information (Ontario).